2017년 4월 7일 금요일

CentOS 6.x X Window 삭제

CentOS 6.x X Window 삭제


서버호스팅을 신청했더니 불필요한 X윈도우까지 설치가 되어 있네요.

삭제하는 방법은 yum 그룹리스트가 있는 확인하고 삭제하면 됩니다.

[root@vps ~]# yum grouplist "X Window System"
Loaded plugins: fastestmirror, security
Setting up Group Process
Loading mirror speeds from cached hostfile
 * base: mirror.oasis.onnetcorp.com
 * epel: mirror.premi.st
 * extras: mirror.oasis.onnetcorp.com
 * rpmforge: ftp.neowiz.com
 * updates: mirror.oasis.onnetcorp.com
Available Groups:
   X Window System
Done
[root@vps ~]# yum groupremove "X Window System"
Loaded plugins: fastestmirror, security
Setting up Group Process
Loading mirror speeds from cached hostfile
 * base: mirror.oasis.onnetcorp.com
 * epel: mirror.premi.st
 * extras: mirror.oasis.onnetcorp.com
 * rpmforge: ftp.neowiz.com
 * updates: mirror.oasis.onnetcorp.com
Resolving Dependencies
--> Running transaction check
---> Package hal.x86_64 0:0.5.14-14.el6 will be erased
--> Processing Dependency: hal >= 0.5.10 for package: hal-info-20090716-5.el6.noarch
--> Processing Dependency: hal = 0.5.14-14.el6 for package: hal-devel-0.5.14-14.el6.x86_64
--> Processing Dependency: hal for package: pm-utils-1.2.5-11.el6.x86_64
---> Package xorg-x11-server-utils.x86_64 0:7.7-14.el6 will be erased
---> Package xorg-x11-xauth.x86_64 1:1.0.9-1.el6 will be erased
---> Package xorg-x11-xinit.x86_64 0:1.0.9-14.el6 will be erased
--> Processing Dependency: xorg-x11-xinit >= 1.0.2-22.fc8 for package: imsettings-0.108.0-3.6.el6.x86_64
--> Running transaction check
---> Package hal-devel.x86_64 0:0.5.14-14.el6 will be erased
---> Package hal-info.noarch 0:20090716-5.el6 will be erased
---> Package imsettings.x86_64 0:0.108.0-3.6.el6 will be erased
---> Package pm-utils.x86_64 0:1.2.5-11.el6 will be erased
--> Processing Dependency: pm-utils for package: libvirt-client-0.10.2-62.el6.x86_64
--> Running transaction check
---> Package libvirt-client.x86_64 0:0.10.2-62.el6 will be erased
--> Processing Dependency: libvirt-qemu.so.0()(64bit) for package: libvirt-devel-0.10.2-62.el6.x86_64
--> Processing Dependency: libvirt.so.0()(64bit) for package: libvirt-devel-0.10.2-62.el6.x86_64
--> Processing Dependency: libvirt-client = 0.10.2-62.el6 for package: libvirt-devel-0.10.2-62.el6.x86_64
--> Processing Dependency: libvirt-client >= 0.9.12 for package: libvirt-java-0.4.9-1.el6.noarch
--> Running transaction check
---> Package libvirt-devel.x86_64 0:0.10.2-62.el6 will be erased
---> Package libvirt-java.noarch 0:0.4.9-1.el6 will be erased
--> Processing Dependency: libvirt-java = 0.4.9-1.el6 for package: libvirt-java-devel-0.4.9-1.el6.noarch
--> Running transaction check
---> Package libvirt-java-devel.noarch 0:0.4.9-1.el6 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                    Arch        Version                Repository  Size
================================================================================
Removing:
 hal                        x86_64      0.5.14-14.el6          @base      1.2 M
 xorg-x11-server-utils      x86_64      7.7-14.el6             @base      364 k
 xorg-x11-xauth             x86_64      1:1.0.9-1.el6          @base       89 k
 xorg-x11-xinit             x86_64      1.0.9-14.el6           @base       71 k
Removing for dependencies:
 hal-devel                  x86_64      0.5.14-14.el6          @base       48 k
 hal-info                   noarch      20090716-5.el6         @base      311 k
 imsettings                 x86_64      0.108.0-3.6.el6        @base      813 k
 libvirt-client             x86_64      0.10.2-62.el6          @base       15 M
 libvirt-devel              x86_64      0.10.2-62.el6          @base      5.0 M
 libvirt-java               noarch      0.4.9-1.el6            @base       73 k
 libvirt-java-devel         noarch      0.4.9-1.el6            @base       15 k
 pm-utils                   x86_64      1.2.5-11.el6           @base      254 k

Transaction Summary
================================================================================
Remove       12 Package(s)

Installed size: 23 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing    : libvirt-devel-0.10.2-62.el6.x86_64                          1/12
  Erasing    : libvirt-java-devel-0.4.9-1.el6.noarch                       2/12
  Erasing    : libvirt-java-0.4.9-1.el6.noarch                             3/12
  Erasing    : hal-devel-0.5.14-14.el6.x86_64                              4/12
  Erasing    : libvirt-client-0.10.2-62.el6.x86_64                         5/12
  Erasing    : hal-info-20090716-5.el6.noarch                              6/12
  Erasing    : hal-0.5.14-14.el6.x86_64                                    7/12
  Erasing    : pm-utils-1.2.5-11.el6.x86_64                                8/12
  Erasing    : imsettings-0.108.0-3.6.el6.x86_64                           9/12
  Erasing    : xorg-x11-xinit-1.0.9-14.el6.x86_64                         10/12
  Erasing    : 1:xorg-x11-xauth-1.0.9-1.el6.x86_64                        11/12
  Erasing    : xorg-x11-server-utils-7.7-14.el6.x86_64                    12/12
  Verifying  : xorg-x11-server-utils-7.7-14.el6.x86_64                     1/12
  Verifying  : pm-utils-1.2.5-11.el6.x86_64                                2/12
  Verifying  : xorg-x11-xinit-1.0.9-14.el6.x86_64                          3/12
  Verifying  : hal-info-20090716-5.el6.noarch                              4/12
  Verifying  : hal-devel-0.5.14-14.el6.x86_64                              5/12
  Verifying  : libvirt-client-0.10.2-62.el6.x86_64                         6/12
  Verifying  : 1:xorg-x11-xauth-1.0.9-1.el6.x86_64                         7/12
  Verifying  : imsettings-0.108.0-3.6.el6.x86_64                           8/12
  Verifying  : hal-0.5.14-14.el6.x86_64                                    9/12
  Verifying  : libvirt-java-devel-0.4.9-1.el6.noarch                      10/12
  Verifying  : libvirt-java-0.4.9-1.el6.noarch                            11/12
  Verifying  : libvirt-devel-0.10.2-62.el6.x86_64                         12/12

Removed:
  hal.x86_64 0:0.5.14-14.el6          xorg-x11-server-utils.x86_64 0:7.7-14.el6
  xorg-x11-xauth.x86_64 1:1.0.9-1.el6 xorg-x11-xinit.x86_64 0:1.0.9-14.el6

Dependency Removed:
  hal-devel.x86_64 0:0.5.14-14.el6        hal-info.noarch 0:20090716-5.el6
  imsettings.x86_64 0:0.108.0-3.6.el6     libvirt-client.x86_64 0:0.10.2-62.el6
  libvirt-devel.x86_64 0:0.10.2-62.el6    libvirt-java.noarch 0:0.4.9-1.el6
  libvirt-java-devel.noarch 0:0.4.9-1.el6 pm-utils.x86_64 0:1.2.5-11.el6

Complete!